
Guided introduction to ReCourse

Introduction

We are going to install ReCourse, and use it to look at a Unit of Learning which has the same structure as the 
LAMS sequence you used last week. 

ReCourse is a reference implementation of the IMS Learning Design specification. This means that it enables 
you to edit the whole of the specification. It also stays quite close the the model of learning activities which 
is the basis of the specification. So when you learn how to use ReCourse, you will also be able to understand 
the structure of an IMS LD Unit of Learning.

This will also be an opportunity to think about the differences between ReCourse and LAMS.
When you have finished working through this document, you will be asked to make some edits to the Unit of 
Learning we are working with.

I suggest that you work in pairs for this task, and for the assessment patch.

1. Setting up ReCourse on your computer

Downloading and installing the application

1 Go to http://tencompetence-project.bolton.ac.uk/ldauthor/index.html 
2 Download the installer that you need for your system. The Windows version with Java will 

probably work best for most of you. 
3 The installer is a zip file. Save it to your hard disk. 
4 Extract the files in the zip package. Probably you can right click on the zip file and choose 兎 xtract 

all 
5 You will then have a folder called ReCourse, and inside it an application, also called ReCourse. 

When you double click on the application it should run without any more configuration. If it does not 
run, then you probably have a Java problem (which is more likely if you have not downloaded the 
Windows version with Java) 

Downloading the Unit of Learning (UOL) we will be using
1 Inside the ReCourse directory, make a new directory called my_UOLs. (UOL means Unit of 

Learning, and it is the name for a lesson created with ReCourse). 
2 Download the LD_Using_ReCourse.zip example Unit of Learning save it in the my_UOLs directory. 
3 Expand the zip files 

2. Looking at Units of Learning

In this activity I will guide you through an introduction to ReCourse. 

There is also a user guide for ReCourse at http://tencompetence-project.bolton.ac.uk/ldauthor/user-
guide.html which you can look at.



2.1 Open a Unit of Learning. In ReCourse:

• Click on the File menu 
• Choose Open 
• Click Browse, and navigate to the my_UOLs folder 
• Open the LD_Using_ReCourse folder 
• Double click on the file imsmanifest.xml. This is the file that has all the information about the 

structure of the Unit of Learning and how it should run. It follows the IMS LD specification. 
• Check the box Add as a bookmark in the library, and in the text box write 鏑 D with Recourse
• Click Open 

2.2. The main parts of ReCourse

You will see the Overview in the main panel. This enables you to describe the Unit of Learning.
At the bottom you can see four tabs: 

Click on them and see what they do.

To the right is the Library panel. The top of it looks like this:

This gives you access to the UOLs you are working with, and the elements that you can include in the UOL 
you have open at the moment.

These tabs and windows show you different views on the structure of the UOL defined in the 
imsmanifest.xml file, together with all the files which make up the content of the Unit of Learning (the 
activity instructions, learning resources, etc.). 

Click on the Design tab in the main panel.
To the left you can see the name of the UOL (in the IMS LD manifest file, the name of the Play, and 
underneath it the two phases of the UOL (in the IMS LD manifest file, the Acts

Notes:
Note 1: file names. You are looking at the Unit of Learning LD_Using_ReCourse

• LD_Using_ReCourse is the file name. 
• Learning Learning Design is the name of the Unit of Learning shown to the learners and teacher 
• There is also a bookmark name used in ReCourse to help you organise your UOLs. I suggested that  

you call it LD with ReCourse You can see this in the Library to the right. 

Note 2: windows. In ReCourse you can move around the panels, drag them off the application as new 



windows, close them and open them with the Window menu. The Window menu also gives you access to 
panels which are not open by default when ReCourse opens. 

3. Working with the Design Grid

3.1 Navigating in the design grid

The yellow area in the middle of the screen is the design grid. 

This is the heart of ReCourse. It is where you can see, create and organise the structure of activities, assign 
them to roles, and connect them to resources. When you double click on one of the elements in the design 
grid you launch the inspector. This gives you information about the element you have selected in the grid, 
and allows you to edit it. Once the inspector is open, it shows information for any element which you click 
on. At the bottom of the “Inspector” window are tabs for the properties associated with the element you are 
looking at. 
In the panel to the left click on “Looking at ReCourse and LD” to make sure that it is selected.
You will see that in the there are two sets of activities:

• About this session 
• Introducing LD 

These are activity structures.

Double click on the About this session activity structure. You can see in the inspector that you can choose a 
structure type for the activity structures. 

I have made them sequences, so that like the LAMS lesson last week, the learners have to go through them 
step by step. If we choose selection, then the learners can do the activities in any order they like.

Click on the little “+” sign by the activity structures to see the activities.



You can see that they are the same activities as you had in the LAMS sequence.

Try editing the activity description for some of them. 

1 Click on the pen icon in the inspector.

2 (If you can't see the pen icon it is because you have not selected the right element in the grid, or 
because the description tab is not selected at the bottom of the inspector). The pen icon launches 
an editor. 

3 When you have finished, just close the editor, and it will invite you to save your changes. 

4 To see your changes in the inspector, click the reload icon 

Click on the second phase “Working in Groups”

You can see that in this phase I have put the activities directly into the grid, not inside an activity structure.

This means that the learners will be able to choose which activity to look at first. 
I have split the class into two groups, and I will give each of them a different forum to work in. 

In the “Working in groups” phase you can see how ReCourse lets you assign activities to roles. 
There are three roles: Group 1, Group 2 and Learner. Try clicking on the grid to change the groups which are 
assigned to the activities. 



3.2 Adding elements to the design grid

Try making a new role.
1 At the top of the design grid there is a button called New... 

2 Click on New... and add a new Learner role. 
3 Call the new role Goup 3
4 Click on the grid to assign an activity to your new role. 

5 Click on New... and add a new Teacher role. 
6 Click on the grid to assign an activity to your new Teacher role. 

Try making a new activity. 
1 Click New at the top of the design grid. 
2 Choose Learning activity 
3 In the dialog box, call your new activity What do you think about ReCourse 
4 Your new activity will appear in the learning grid. 

5 Double click on it, and use the pen icon to edit the text. 

6 Add some simple text, like “Work in your groups to prepare a presentation about recourse”
7 In the grid, click on the columns so it is available to Group 1, Group 2 and Group 3. 

Try making a new phase. 
1. Find the list of modules and phases to the left of the design grid. 

2. Click the “New...” button above this list. 
3. Choose “Phase”. 
4. You can drag the phases up and down to change the sequence. 



4. Seeing the big picture of the Unit of Learning

4.1 The Visualiser

The Visualiser gives you a picture of the whole Unit of Learning.
1 Go to the Window menu 
2 Click on Visualiser. You should see something like this:

1 To make more room for the Visualiser, 
• right click on the Visualiser tab title Visualiser LD with ReCourse  
• Click Detached. You could do the same thing by dragging the pane off the ReCourse 

application. 
2 Make the window bigger. 
3 Explore the structure of the UOL by double clicking on the nodes, and by using the icons at the top of 

the Visualiser window. 
4 If you want, you can put the Visualiser back into the application by right clicking on its tab title and 

clicking Detached again. You can also go to the Window menu and choose Reset Window Layout, 
which puts all the windows back to their default position. 

4.2 The Library Panel.

At the bottom of the library panel are some tabs.

In order from left to right, these are:
• Your Unit of Learning Bookmarks (icon: the letters L D)
• Activities (icon: three documents) 
• Environments (icon: a bag) 
• Roles (icon: a person) 
• Resources (icon: the world) 

Use these tabs to see the new roles and activities you have created.
You can also create roles and activities in the library (try using a right click), and use them on the grid when 
you need them.
If you delete an element on the grid it does not delete it from the library.



5. Resources and services for the learning activities

Up to now we have looked at activities and roles.
But we have not given our students anything to work with.
We do this with the Resources and Environments tabs of the main panel
An Environment is a container for learning resources and services. It is called an “Environment” because in 
the real world any learning activity happens in a context, with resources and services which support the 
activity. Because it is a separate component the same environment can be used with different activities. Now 
we can explore the environments in “LD with ReCourse”

1 Click on the Environments tab of the main panel. 

2 Each of the boxes with a blue top is an environment. Find the “What is Learning Design” 
environment. 

3 Double click on the book icon in the “What is Learning Design” environment. In the inspector you 
can see the text of the resource. You can edit it if you want to. 

4 Click on the book icon in the EML to LD environment. 
5 You will see a link to Professor Olivier's presentation on LD. Click on it and it will open. 

5.1 Managing resources in a UOL

The Resources tab gives you access to a content management system built into ReCourse. 

You only need the Resources tab when you want to:
• manage the files which you have created as part of your UOL, and references to the files
• import external resources into your UOL (for example the presentation on LD) 

The Resources in the file area are also shown in the resources tab of the library (last to the right at the 
bottom of the library). Click on this icon to see what it does.



6. Working with environments

People who are new to IMS Learning Design and ReCourse often find environments difficult to work with. 
But it is not complicated if you understand that:

1 An environment needs to have references to files and services. For files you do this by using the 
inspector to edit a knowledge object. For services you can drag them directly from the palette onto 
the environment. 

2 Learners and teachers can only use an Environment if it is associated with an activity. You do 
this by using the inspector to edit an activity in the design grid, or in the activities library. 

Now we will look at these two points, starting by adding files to a learning object. 
To add a resource to a learning object.

1 Go to the Environments tab. 
2 Drag “Add Environment” onto the Environments area 

3 Double click the name Environment in the blue area at the top of your new environment. Give it a 
name like “My new environment”

4 Drag a Knowledge object from the Palette onto “My new environment” 

5 Double click the name of your new Knowledge Object. Give it a new name like “My new learning 
resource”

6 Double click the name of  “My new learning resource” to open the inspector. 
7 A file has automatically been created and associated with the new knowledge object. You can edit it 

by clicking on the pen icon. You could find the file in the resources area if you want to. 

If you want to associate a different file with the new knowledge object you can do that with the “Show item 
editor” icon, last icon to the right in the inspector for the knowledge object. 

1. Click the “Show item editor” icon. 
2. In the library, click the tab with a little world icon. If you keep the mouse over it you get a rollover 

text “Resources in selected learning design” 
3. Drag resources from the library onto the inspector for the knowledge object you want to change. You 

can delete knowledge objects with the red cross icon, and view them with the glasses icon. 

To add a service to a UOL you have to connect to a Wookie server. 
1. Go to the menu “tools” and choose “Query widgets”
2. In the “URL:” field paste http://213.246.232.126:8090/wookie/advertise?all=true#

 You can now drag any widget service onto an environment.
(Notice that the icon changes, but the name stays the same)

http://213.246.232.126:8090/wookie/advertise?all=true


Associating an environment with a learning activity.

To make the environment available to learners you have to associate it with a learning activity.
1 Go to the Design tab of the main panel. 
2 Chose a learning activity from the yellow design grid (if you have activity groups on your grid you 

will have to click the little icon by the side of the activity group to see the activities). 
3 Double click the activity to show the inspector 
4 At the bottom of the inspector are some tabs. The first is “Description” and the second is 

“Environments”. Click on “Environments”.
5 You can see all the environments in the UOL. Use the check boxes to choose which ones should be 

associated with this learning activity. 



7. What we have not looked at in this introduction

There is a lot more in ReCourse which we have not looked at in this introduction. 

Firstly, there are many details which we have not had time to look at which you will only learn if you have 
time to practice using the application to make UOLs

Secondly, we have only looked at Level A of IMS LD. Level B enables you to use properties and conditions 
to control the flow of information in a UOL, and the progress of students through it. For example you can use 
this to make branching structures which the students follow according to the results of their work. 

You can also use Level B to show properties in XHTML pages, showing a score or some text input from 
students.

If you want to see what this looks like, open the 360 degree assessment UOL in ReCourse, and choose 
Properties and Conditions from the Window menu. 

Level C of IMS LD lets you instruct the system to generate messages. 
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